PIM-X Bug on Win7 SP1 - Fixed!

Started by CasperVg, January 03, 2012, 10:27:01 PM

Previous topic - Next topic

0 Members and 1 Guest are viewing this topic.

Aaron Graham

-Simcity4fan12/Sgt Pepper -Kryptowhite -Jumpthefence -beutelschlurf -Hanson784 -Gwail -Don Miguel -Seraf -Kelistmac -Glenni -Aaron Graham -Vlasky -PBGV103 -Darknono35 -Evillions -lucky7- Parisian- Jackreid -GuerrilaWarfare -Sim Fox -un1 -Heblem -AlexandrosB13 -Anotn -SimHoTToDDy


This is pefect! Thank you, Casper. :)




A big thank you, it's work fine !  :thumbsup:


Forgot my password but had to reset it just to thank you for your work!  &apls

Your fix helped with the "dll load failed: The parameter is incorrect" bug I had when starting the SC4 Savegame Explorer on Windows 7 SP1.

Guys like you are the reason why I like the SC4 community so much :thumbsup:


Brilliant, this worked like a charm!   ;D
Thanks a lot for the fix Casper  :thumbsup:

A Nonny Moose

Quote from: CasperVg on January 04, 2012, 04:15:54 AM
I have never personally encountered this issue on SC4 Terraformer (it always ran fine on my Win7 SP1 64bit, without changes (same for Datpacker, Cleanitol etc)). But if you're talking about this thread/problem. Then yes, it could probably be solved in a similar way. Can you try adding multiarray.pyd to your SC4TF program files directory and see if that solves anything?

Contrary to SC4PIM though, there is no multiarray.pyd in the program folder of SC4TF itself. But the library.zip (which can't be edited afaik) does contain it.

Hope it helps,
(it was me who found the solutions btw ;)

Hi Casper.

If you have to edit a .zip, the Archive Manager in Linux can do it.  Just create a (Ubuntu) live CD, and you can use it without installing the O/S simply by booting from the disk.


My Canada includes Quebec


Quote from: A Nonny Moose on October 04, 2012, 06:19:05 PM

Hi Casper.

If you have to edit a .zip, the Archive Manager in Linux can do it.  Just create a (Ubuntu) live CD, and you can use it without installing the O/S simply by booting from the disk.


Heh, that's not a bad idea. I'll definitely check that out. I already dualboot Ubuntu (need it for my CompSci classes) but hadn't thought of using the archive manager to do it.
Follow my SimCity 4 Let's play on YouTube


I even had a curiosity to ask why this moose was never here ...
Glad to know that the link has brought you to a subject to post.


Hey folks!
I just wanted to thank you for the bugfix, works like a charm now. Now I just need to figure out how to use it^^



Thanks for the fix, Casper. I hadn't tried to run SC4PIM since I installed SP1 so when it wouldn't start up I looked here. It works properly now.
Inside every old person is a young person wondering what happened. TP

Barbypedia: More alive than the original


I may be stupid but I can not find the bug-fix file. It does not appear to be attached to this forum. Am I missing something?


I guess I am stupid :).   Just after sending the above question I found the file. I installed it, and it works!  Thanks anyway.  My next problem is install the Maxis Building Architect Tool.  Though I put it in the SC4 Directory, I am told it can't find SimCity.


I am running Win8 64bit.  I was getting this error when starting PIMx:

QuoteTraceback (most recent call last):
  File "SC4PIM.py", line 1, in ?
  File "SC4PIMApp.pyo", line 96, in ?
  File "wx\__init__.pyo", line 45, in ?
  File "wx\_core.pyo", line 4, in ?
  File "wx\_core_.pyo", line 12, in ?
  File "wx\_core_.pyo", line 10, in __load
ImportError: DLL load failed: The specified module could not be found.

I tried putting the new multiarray.pyd file into my SC4PIM folder and it didn't change my results. 

I changed my compatibility settings to: run in compatibility mode for 'WinXP (service pack 2)' and 'run program as administrator', now the program works perfectly again. 

Just thought I would mention this in case somebody else forgot about compatibility settings like I had momentarily.


Finally got PIM-X to work, THANK YOU!!! Now, if the LEX download would only include the fix (or at least direct you to the fix!)


You're right, rajwarrior. I've added a link to the bugfix in the PIM-X LEX description and comment section so that people with this issue will find the solution more quickly in the future
Follow my SimCity 4 Let's play on YouTube


I got this error when moving the files:

Traceback (most recent call last):
  File "SC4PIMApp.pyo", line 3136, in OnBeginDrag
  File "SC4Data.pyo", line 50, in __getitem__

I don't know why this is happening. I tried Running in Compatability mode and as Administrator.

I'll try to add parameters and see if it helps.

I will get back to you soon